Invoice Reminder Issue
Incident Report for Simply Hosting & Servers
Resolved
This incident has been resolved.
Posted Feb 27, 2017 - 09:18 GMT
Monitoring
We are currently upgrading our billing platform and during the process some customers may have incorrectly received invoices.

Affected clients should have received an email with further details.
Please accept our apologies for any confusion this may have caused and disregard these invoices, being assured that all services will be billed correctly.

If you have any queries, please do not hesitate to contact us directly.

Simply Hosting & Servers.
Posted Feb 23, 2017 - 10:32 GMT