Customer Portal
Incident Report for Simply Hosting & Servers
Resolved
This incident has been resolved.
Posted 11 months ago. Oct 09, 2018 - 16:20 BST
Update
We are continuing to monitor for any further issues.
Posted 11 months ago. Oct 09, 2018 - 16:20 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted 11 months ago. Oct 09, 2018 - 14:23 BST
Investigating
Hello, We are currently experiencing slow response times on the customer portal
Posted 11 months ago. Oct 09, 2018 - 14:13 BST
This incident affected: Management Portal.