Phone System Issues
Incident Report for Simply Hosting & Servers
Resolved
We now consider this issue resolved.
Posted about 2 months ago. Aug 29, 2019 - 17:40 BST
Monitoring
A fix has been implemented and the phone system should now be working as intended.

There may be further work required in the future to ensure that the fix is working correctly.
Posted 5 months ago. May 29, 2019 - 12:09 BST
Investigating
We are currently facing issues with our phone system where customers may be put on hold indefinitely.

If you face this issue then please raise a ticket instead using our support portal.
Posted 5 months ago. May 28, 2019 - 20:47 BST