Backup2.simplyhosting.com
Incident Report for Simply Hosting & Servers
Resolved
This has now been resolved
Posted 18 days ago. Feb 05, 2019 - 14:27 GMT
Investigating
Backup 2 is currently experiencing issues with its report email function, the issue is being worked on.
Posted 5 months ago. Oct 03, 2018 - 09:05 BST
This incident affected: Backup Servers.