Network Circuit Issues

Incident Report for Simply Hosting

Resolved

Both suppliers of different international circuits have repaired their services overnight in the EU. The Network is now operating with normally expected levels of resilience.
Posted Oct 03, 2025 - 08:37 BST

Update

Both suppliers of different international circuits are mobilising engineers and replacement equipment to their affected locations in the EU with priority.
Posted Oct 02, 2025 - 19:23 BST

Investigating

Our monitoring has detected 2 independent issues on circuits to our other European locations. Whilst we still have upstream connectivtiy from that location and resilient connectivity to another core pop datacenter we as such rely on this site at the current time and would consider this an at-risk situation for Network.

We are progressing fault tickets with both carriers with the highest priority to restore normal resilience levels.
Posted Oct 02, 2025 - 14:36 BST
This incident affected: Network Status.