Switch failure in 1 rack - Reading N17

Incident Report for Simply Hosting

Resolved

This incident has been resolved.
Posted Mar 27, 2026 - 17:10 GMT

Monitoring

We will continue to monitor over the next couple of hours
Posted Mar 27, 2026 - 13:10 GMT

Update

The switch has now been replaced, and the rack is back online
Posted Mar 27, 2026 - 13:08 GMT

Identified

Our monitoring has identified a failed network switch in our Reading datacentre rack N17 affecting a small number of dedicated server customers in that rack. The switch is currently under replacement and we expect servers to return online soon. We will post a further update once complete.
Posted Mar 27, 2026 - 12:41 GMT